Configuring LAG for the AP

Configuring LAG(link aggregation) allows the AP to provide 2 Gbps uplink.

Configuring WLC

  1. Use the command “config ap lag-mode support enable” to enable global LAG support. This will cause the DTLS connection to be down.
  2. Use the command “config ap lag lag-mode support enable <ap name>” to enable LAG support for the AP. This will cause the AP to reboot. This command has the same effect as executing “capwap ap lag enable” on the AP.
Plain text
Copy to clipboard
Open code in new window
EnlighterJS 3 Syntax Highlighter
(Cisco Controller) >config ap lag-mode support enable
Warning! DTLS connection with all APs will be teared down causing
them to disjoin and rejoin again.
Are you sure you want to continue? (y/n) y
Warning: AP behind NAT/PAT will not be supported.
(Cisco Controller) >config ap lag-mode support enable AP38
Warning! AP will be rebooted.
Are you sure you want to continue? (y/n) y
(Cisco Controller) >config ap lag-mode support enable Warning! DTLS connection with all APs will be teared down causing them to disjoin and rejoin again. Are you sure you want to continue? (y/n) y Warning: AP behind NAT/PAT will not be supported. (Cisco Controller) >config ap lag-mode support enable AP38 Warning! AP will be rebooted. Are you sure you want to continue? (y/n) y
(Cisco Controller) >config ap lag-mode support enable 

Warning! DTLS connection with all APs will be teared down causing
 them to disjoin and rejoin again. 
 Are you sure you want to continue? (y/n) y


Warning: AP behind NAT/PAT will not be supported.

(Cisco Controller) >config ap lag-mode support enable AP38

Warning! AP will be rebooted. 
 Are you sure you want to continue? (y/n) y

Configuring the switch

I used LACP, but we can also use ON mode.

Plain text
Copy to clipboard
Open code in new window
EnlighterJS 3 Syntax Highlighter
Switch(config)#port-channel load-balance src-dst-port
Switch(config)#int range gigabitEthernet 1/0/3, gigabitEthernet 1/0/5
Switch(config-if-range)#channel-group 1 mode active
Switch#sh run int port-channel 1
Building configuration...
Current configuration : 125 bytes
!
interface Port-channel1
switchport trunk native vlan 69
switchport trunk allowed vlan 1-3000
switchport mode trunk
end
Switch(config)#port-channel load-balance src-dst-port Switch(config)#int range gigabitEthernet 1/0/3, gigabitEthernet 1/0/5 Switch(config-if-range)#channel-group 1 mode active Switch#sh run int port-channel 1 Building configuration... Current configuration : 125 bytes ! interface Port-channel1 switchport trunk native vlan 69 switchport trunk allowed vlan 1-3000 switchport mode trunk end
Switch(config)#port-channel load-balance src-dst-port
Switch(config)#int range gigabitEthernet 1/0/3, gigabitEthernet 1/0/5
Switch(config-if-range)#channel-group 1 mode active


Switch#sh run int port-channel 1
Building configuration...

Current configuration : 125 bytes
!
interface Port-channel1
 switchport trunk native vlan 69
 switchport trunk allowed vlan 1-3000
 switchport mode trunk
end

Verification

Plain text
Copy to clipboard
Open code in new window
EnlighterJS 3 Syntax Highlighter
Switch#show etherchannel summary
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
A - formed by Auto LAG
Number of channel-groups in use: 1
Number of aggregators: 1
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SU) LACP Gi1/0/3(P) Gi1/0/5(P)
Switch#
Switch#show interfaces gigabitEthernet 1/0/5 counters
Port InOctets InUcastPkts InMcastPkts InBcastPkts
Gi1/0/5 1261761 10609 6 2
Port OutOctets OutUcastPkts OutMcastPkts OutBcastPkts
Gi1/0/5 1260384 10587 94 65
Switch#show interfaces gigabitEthernet 1/0/3 counters
Port InOctets InUcastPkts InMcastPkts InBcastPkts
Gi1/0/3 11558 35 6 0
Port OutOctets OutUcastPkts OutMcastPkts OutBcastPkts
Gi1/0/3 10295 60 18 22
Switch#
Switch#show etherchannel summary Flags: D - down P - bundled in port-channel I - stand-alone s - suspended H - Hot-standby (LACP only) R - Layer3 S - Layer2 U - in use f - failed to allocate aggregator M - not in use, minimum links not met u - unsuitable for bundling w - waiting to be aggregated d - default port A - formed by Auto LAG Number of channel-groups in use: 1 Number of aggregators: 1 Group Port-channel Protocol Ports ------+-------------+-----------+----------------------------------------------- 1 Po1(SU) LACP Gi1/0/3(P) Gi1/0/5(P) Switch# Switch#show interfaces gigabitEthernet 1/0/5 counters Port InOctets InUcastPkts InMcastPkts InBcastPkts Gi1/0/5 1261761 10609 6 2 Port OutOctets OutUcastPkts OutMcastPkts OutBcastPkts Gi1/0/5 1260384 10587 94 65 Switch#show interfaces gigabitEthernet 1/0/3 counters Port InOctets InUcastPkts InMcastPkts InBcastPkts Gi1/0/3 11558 35 6 0 Port OutOctets OutUcastPkts OutMcastPkts OutBcastPkts Gi1/0/3 10295 60 18 22 Switch#
Switch#show etherchannel summary 
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port

        A - formed by Auto LAG


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         LACP      Gi1/0/3(P)  Gi1/0/5(P)  

Switch#
Switch#show interfaces gigabitEthernet 1/0/5 counters 

Port            InOctets    InUcastPkts    InMcastPkts    InBcastPkts 
Gi1/0/5          1261761          10609              6              2 

Port           OutOctets   OutUcastPkts   OutMcastPkts   OutBcastPkts 
Gi1/0/5          1260384          10587             94             65 
Switch#show interfaces gigabitEthernet 1/0/3 counters 

Port            InOctets    InUcastPkts    InMcastPkts    InBcastPkts 
Gi1/0/3            11558             35              6              0 

Port           OutOctets   OutUcastPkts   OutMcastPkts   OutBcastPkts 
Gi1/0/3            10295             60             18             22 
Switch#

Leave a Reply

Your email address will not be published.