Initially configure an ISR 1100 router

Ports

Connect the GigabitEthernet port to the upstream switch.

interface GigabitEthernet0/1/0
 switchport trunk native vlan 3
 switchport mode trunk
interface Vlan35
 ip address 10.1.3.122 255.255.255.0

Configure the wireless interface, the configuration is the same as the GigabitEthernet port.

interface Wlan-GigabitEthernet0/1/4
 switchport trunk native vlan 3
 switchport mode trunk

We may also need to configure the default route.

ip route 0.0.0.0 0.0.0.0 10.1.3.1

After configuration, it is probably as follows.

ISR1100#show ip int brief 
Interface              IP-Address      OK? Method Status                Protocol
GigabitEthernet0/0/0   unassigned      YES NVRAM  up                    up      
GigabitEthernet0/1/0   unassigned      YES unset  up                    up      
GigabitEthernet0/1/1   unassigned      YES unset  down                  down    
GigabitEthernet0/1/2   unassigned      YES unset  down                  down    
GigabitEthernet0/1/3   unassigned      YES unset  down                  down    
Wl0/1/4                unassigned      YES unset  up                    up      
Cellular0/2/0          unassigned      YES NVRAM  down                  down    
Cellular0/2/1          unassigned      YES NVRAM  administratively down down    
ATM0/3/0               unassigned      YES NVRAM  down                  down    
Ethernet0/3/0          unassigned      YES NVRAM  down                  down    
Vlan1                  unassigned      YES unset  up                    up      
Vlan3                  10.1.3.122      YES NVRAM  up                    up      
ISR1100#

AP module

Confirm the slot and status.

ISR1100#show platform 
Chassis type: C1117-4PLTELAWZ

Slot      Type                State                 Insert time (ago) 
--------- ------------------- --------------------- ----------------- 
0         C1117-4PLTELAWZ     ok                    04:34:20      
 0/0      C1117-1x1GE         ok                    04:32:35      
 0/1      C1117-ES-4          ok                    04:32:35      
 0/2      C1117-LTE           ok                    04:32:35      
 0/3      C1117-VADSL-A       ok                    04:32:35      
 0/4      ISR-AP1100AC-Z      ok                    04:32:35      
R0        C1117-4PLTELAWZ     ok, active            04:34:20      
F0        C1117-4PLTELAWZ     ok, active            04:34:20      
P0        PWR-12V             ok                    04:33:55      

Slot      CPLD Version        Firmware Version                        
--------- ------------------- --------------------------------------- 
0         17100501            16.6(1r)                            
R0        17100501            16.6(1r)                            
F0        17100501            16.6(1r)                            

ISR1100#

Enter the AP command line mode. The configuration process is exactly the same as Mobility Express.

ISR1100#hw-module session 0/4           
Establishing session connect to subslot 0/4
To exit, type ^a^q

picocom v2.2

port is        : /dev/ttyS3
flowcontrol    : none
baudrate is    : 9600
parity is      : none
databits are   : 8
stopbits are   : 1
escape is      : C-a
local echo is  : no
noinit is      : no
noreset is     : no
nolock is      : yes
send_cmd is    : sz -vv
receive_cmd is : rz -vv -E
imap is        : 
omap is        : 
emap is        : crcrlf,delbs,
logfile is     : none

Type [C-a] [C-h] to see available commands

Terminal ready

Enter Administrative User Name (24 characters max): admin
Enter Administrative Password (3 to 24 characters): ********
Re-enter Administrative Password                 : ********

System Name [Cisco_1c:ae:20] (31 characters max): ISR-AP

Enter Country Code list (enter 'help' for a list of countries) [US]: US

Configure a NTP server now? [YES][no]: no
Configure the system time now? [YES][no]: no

Note! Default NTP servers will be used

Management Interface IP Address Configuration [STATIC][dhcp]: 

Management Interface IP Address: 10.1.3.125
Management Interface Netmask: 255.255.255.0
Management Interface Default Router: 10.1.3.1
Cleaning up Provisioning SSID
As the Mgmt Address is updated, all the DHCP scopes with Central NAT enabled will be disabled and enabled
As the Mgmt Address is updated, all the WLANs associated with central NAT enabled scopes will be enabled and disabled

Create Management DHCP Scope? [yes][NO]: 
Employee Network Name (SSID)?: test
Employee Network Security? [PSK][enterprise]: 
Employee PSK Passphrase (8-63 characters)?: ********
Re-enter Employee PSK Passphrase: ********
Enable RF Parameter Optimization? [YES][no]: no

Configuration correct? If yes, system will save it and reset. [yes][NO]: yes
Cleaning up Provisioning SSID

Configuration saved!
Resetting system with new configuration...

After the configuration is complete, the AP module will be reloaded (the ISR1k itself will not reload).

If we need to exit the AP command line mode, we can type Ctrl+A and then Ctrl+Q.

(Cisco Controller) >
Thanks for using picocom
ISR1100#

Upgrade

Upgrade ISR1k

Download the ISR1k image from official website, then copy to the bootflash.

ISR1100#copy ftp://admin:password@10.1.1.1/c1100-universalk9_ias.16.09.06.SPA.bin bootflash:

Check the bootflash to see uploaded image file.

ISR1100#dir bootflash:
Directory of bootflash:/

   11  -rw-               30  Dec 15 2020 05:44:49 +00:00  throughput_monitor_params
16321  drwx             4096  Dec 15 2020 05:43:06 +00:00  .installer
   12  drwx             4096   Feb 3 2019 11:11:07 +00:00  lost+found
65281  drwx             4096  Oct 14 2018 15:55:01 +00:00  core
57121  drwx             4096  Jul 28 2020 11:34:08 +00:00  .prst_sync
32641  drwx             4096  Jun 22 2018 14:25:21 +00:00  .rollback_timer
   13  -rw-               35  Dec 15 2020 05:46:17 +00:00  pnp-tech-time
40801  drwx            16384  Dec 15 2020 13:28:22 +00:00  tracelogs
   14  -rw-            52249  Dec 15 2020 05:46:27 +00:00  pnp-tech-discovery-summary
   15  -rw-              656  Dec 15 2020 10:11:57 +00:00  vlan.dat
   17  -rw-        427968764  Jun 23 2018 05:56:22 +00:00  c1100-universalk9_ias.16.08.01.SPA.bin
171361  drwx             4096  Jul 28 2020 11:34:17 +00:00  onep
   16  -rw-        462560512  Dec 15 2020 13:28:18 +00:00  c1100-universalk9_ias.16.09.06.SPA.bin
   22  -rw-        387843132  Jun 25 2018 11:46:41 +00:00  c1100-universalk9_ias.16.07.02.SPA(1).bin
   30  -rw-        525416452  Oct 14 2018 15:39:30 +00:00  c1100-universalk9_ias.2018-10-08_13.46_andakshi.SSA.bin
130563  drwx             4096   Feb 3 2019 11:11:16 +00:00  cflow
   33  -rw-        458170120  Dec 10 2018 15:51:13 +00:00  c1100-universalk9_ias.16.09.01.SPA.bin
114241  drwx             4096  Jun 27 2018 08:00:51 +00:00  gs_script
122401  drwx             4096  Jul 28 2020 11:29:39 +00:00  .dbpersist
163201  drwx             4096  Jun 27 2018 08:01:18 +00:00  virtual-instance
106081  drwx             4096  Jun 27 2018 08:01:18 +00:00  vman_fdb
   40  -rw-        353746220  Jun 27 2018 12:34:27 +00:00  c1100-universalk9_ias.16.06.01.SPA.bin

2908606464 bytes total (112234496 bytes free)
ISR1100#
ISR1100#

Using the uploaded image file to boot.

ISR1100(config)#boot system flash bootflash:c1100-universalk9_ias.16.09.06.SPA.bin 
ISR1100(config)#config-reg 0x2102
ISR1100(config)#end
ISR1100#show run | include boot

*Dec 15 13:29:58.508: %SYS-2-PRIVCFG_ENCRYPT: Successfully encrypted private config fileboot-start-marker
boot system flash bootflash:c1100-universalk9_ias.16.09.06.SPA.bin
boot-end-marker
license boot level appxk9
diagnostic bootup level minimal
ISR1100#copy run start
Destination filename [startup-config]? 
Building configuration...

[OK]
ISR1100#
*Dec 15 13:30:23.112: %SYS-2-PRIVCFG_ENCRYPT: Successfully encrypted private config filerelo
ISR1100#       
ISR1100#
ISR1100#
ISR1100#relo
ISR1100#reload 
The following license(s) are transitioning, expiring or have expired.
Features with expired licenses may not work after Reload.
Feature: appxk9                         ,Status: transition, Period Left: 8  wks 1  day  

Proceed with reload? [confirm]

*Dec 15 13:30:32.937: %SYS-5-RELOAD: Reload requested by console. Reload Reason: Reload Command.Rom image verified correctly


System Bootstrap, Version 16.6(1r), RELEASE SOFTWARE
Copyright (c) 1994-2017  by cisco Systems, Inc.


Current image running: Boot ROM0

Last reset cause: LocalSoft
C1117-4PLTELAWZ platform with 4194304 Kbytes of main memory


........

Located c1100-universalk9_ias.16.09.06.SPA.bin

Upgrade Controller

(Cisco Controller) >transfer download ap-images serverIp 10.1.1.1

(Cisco Controller) >transfer download ap-images mode tftp 

(Cisco Controller) >transfer download ap-images imagePath /haifeli/image/ISR1100/ISR-AP1100AC-ME-8-10-142-0

(Cisco Controller) >transfer download start 

Mode............................................. TFTP  
Data Type........................................ ap-image
TFTP Server IP................................... 10.1.1.1
TFTP Packet Timeout.............................. 6
TFTP Max Retries................................. 10
TFTP Path........................................ /haifeli/image/ISR1100/ISR-AP1100AC-ME-8-10-142-0/

Do you want to Auto-Reboot after Complete? (y/N) y
Auto-Reboot check ENABLED!!
System will reboot within 5secs, ONLY upon Download COMPLETION to all Aps.
Configuration will be Saved before Auto-Reboot

DOWNLOAD may take some time......
Are you sure you want to start? (y/N) y

TFTP Code transfer starting.

Triggered APs to pre-download the image.
Controller will AUTOREBOOT once AP Image pre-download is complete.  




(Cisco Controller) >
(Cisco Controller) >show ap image all 

Total number of APs.............................. 1
Number of APs
        Initiated....................................... 0
        Downloading..................................... 0
        Predownloading.................................. 1
        Completed predownloading........................ 0
        Not Supported................................... 0
        Failed/Waiting to Predownload................... 0

                                                 Predownload     Predownload                                  Flexconnect    Failure              Download
AP Name            Primary Image  Backup Image   Status          Version        Next Retry Time  Retry Count  Predownload    Reason               Progress
------------------ -------------- -------------- --------------- -------------- ---------------- ------------ -------------- -------------------- ----------
AP1111.X11X.XXXX   8.5.107.87     0.0.0.0        Predownloading  --             NA               0           NA              NA                    18% 

(Cisco Controller) >

Picocom

Picocom is a minimal dumb-terminal emulation program. When switching the command line mode, we can see that Cisco uses Picocom.

References

Wireless Device Overview
picocom
Linux下小巧的COM口連接軟件 Picocom
How to Install and Upgrade the Software

You may also like...

Leave a Reply

Your email address will not be published. Required fields are marked *